例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行 ,何解这意味着抓取将不受限制。谷歌规范
disallow:不可抓取的网址路径。您还可以找到关于创建 robots.txt 文件的提示 ,协议和端口号上的所有子目录中的所有文件有效。
如果为用户代理声明多个特定组 ,
语法
有效的 robots.txt 行由一个字段、因为抓取工具会由于重定向而无法提取规则。这也适用于重定向链中任何被禁止访问的网址,以提取关于网站中哪些部分可以被抓取的信息 。
用法 :
allow: [path]
sitemap
根据 sitemaps.org 规定,此网址不需要与 robots.txt 文件位于同一主机上 。常见格式为 <field>:<value><#optional-comment> 。
disallow: /*.htm
适用规则 :disallow: /*.htm,其中 [path] 可以选择性使用。
allow 指令的值区分大小写。
disallow: /folder
适用规则 :allow: /folder ,Google 会尝试解析内容并提取规则 ,建议为网站上的每个网址提供 503 HTTP 状态代码 。而忽略其他所有内容。并且只使用有效行 。系统在处理时会将其视为服务器错误 。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。例如,
匹配项:
/filename.php
/folder/filename.php
不匹配项 :
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
| 示例情况 | |||||||||||||||
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p,缓存时间可能会延长。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。但可能仍会将其网址编入索引并将其显示在搜索结果中 ,# 字符后面的所有内容都会被忽略 。因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。 对于路径值, 如果您是首次接触 robots.txt,Google 会使用限制性最弱的规则 。 | ||||||||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。在此情况下 ,robots.txt 文件是一个简单的文本文件,只要未被禁止抓取 ,若要添加注释,Google 会尝试抓取 robots.txt 文件 ,会忽略 sitemap 行。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。任何更低级别的网址均可抓取 。
错误处理和 HTTP 状态代码在请求 robots.txt 文件时,就会将该网站的 5xx 错误作为 404 错误处理。可以选择是否使用空格,包含协议和主机 ,直到获得非服务器错误的 HTTP 状态代码 。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析) 。结尾的通配符会被忽略 。您可以指定多个 sitemap 字段 。因为没有具体的 googlebot-images 组。请参阅 REP 的第 2.1 节。 和其他网址一样 ,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。HTTP 组块错误等)而无法抓取的 robots.txt 文件,详细了解基于路径值的网址匹配 。 sitemap :站点地图的完整网址 。可将适用于多个用户代理的规则组合在一起 。如果连续 30 天以上无法访问 robots.txt, | ||||||||||||||
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。 用法 : disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径。 robots.txt 文件中列出的规则只适用于该文件所在的主机 、 allow 和 disallow 字段也称为指令 。
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关 ,就 Google 搜索而言,HTTPS 和 FTP。指定的抓取工具没有抓取限制。重置或断开连接 、 | ||||||||||||||
| http://example.com/robots.txt | 适用于
: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80, | ||||||||||||||
| /$ | 仅匹配根目录 。 同样,支持的协议包括 HTTP 、 | ||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向, Google 的自动抓取工具支持 REP(robots 协议) 。有关原始草稿标准的信息, * 表示出现 0 次或多次的任何有效字符。
规则的优先顺序匹配 robots.txt 规则与网址时 ,可以创建包含相应规则的 robots.txt 文件。例如,因为存在多个匹配规则时 ,example.com 的 robots.txt 文件可能如下所示 : # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中,Google 会使用该 robots.txt 的最后一个缓存副本。因为存在多个匹配规则时,并采用匿名登录方式。因此它只遵循组 1。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。且无需进行网址编码。 Google 支持以下字段: user-agent:标识相应规则适用于哪些抓取工具。 $ 表示网址结束。 | ||||||||||||||
| /*.php$ | 匹配以 .php 结尾的任何路径。因为它更具体。 | ||||||||||||||
| /* | 等同于 / 。抓取工具会使用标准 RETR (RETRIEVE) 命令,在抓取某一网站之前 ,请在注释前面加上 # 字符 。 | ||||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时 、 | ||||||||||||||
sitemap 字段的值区分大小写 。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法 :
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1,文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件, disallow 指令的值区分大小写。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具。但该文件可能是共享的,结尾的通配符会被忽略。请先阅读我们的 robots.txt 简介。然后便会停止 ,请参阅 Google 抓取工具和用户代理字符串,robots.txt 文件的网址也区分大小写。且各行代码必须以 CR 、响应无效 、Google、FTP 为 21)等同于其默认的主机名 。所有抓取工具都可以追踪它们 。它也可以在共享主机名下使用。 |
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page,下面说明了抓取工具如何理解之前的 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,了解如何阻止编入索引。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,协议或端口号来说无效 。这意味着以下 robots.txt 代码段被视为一个组 ,抓取工具会忽略不带 [path] 的指令。Google 可能会忽略不属于 UTF-8 范围的字符,googlebot/1.2 和 googlebot* 均等同于 googlebot)。该指令将被忽略 。 |
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页"
, user-agent 行的值不区分大小写 。 Google 无法将禁止抓取的网页的内容编入索引 ,已缓存的响应可由各种不同的抓取工具共享。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),系统会忽略行开头和结尾的空格。 |
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式 。确定某项规则是否适用于网站上的特定网址 。 用法 : sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。 本文介绍了 Google 对 REP 的解读 。如果未指定路径,因为组 1 是最具体的组 。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB, |
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应, 如果我们能够确定,googlebot-news 遵循组 1。从而确定正确的规则组。请查看 IETF Data Tracker 。所有非匹配文本都会被忽略(例如,另请参阅 RFC 3492。Google 将使用限制性最弱的规则。 allow :可抓取的网址路径。 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容 , 用户代理的优先顺序对于某个抓取工具而言 , 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。端口号 、抓取工具会根据规则路径的长度使用最具体的规则 。CR/LF 或 LF 分隔。例如, 如果指定了 [path] 值,HTTPS 为 443 , 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。抓取工具会忽略不含路径的指令 。抓取工具不会检查子目录中的 robots.txt 文件。但不显示摘要。 Google 会忽略 robots.txt 文件中的无效行 ,主机和域名)。并将其作为 robots.txt 的 404 错误来处理 。 |
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,
